[ALSA-2022:2074] Moderate: samba security, bug fix, and enhancement update
Type:
security
Severity:
moderate
Release date:
2022-05-10
Description:
Samba is an open-source implementation of the Server Message Block (SMB) protocol and the related Common Internet File System (CIFS) protocol, which allow PC-compatible machines to share files, printers, and various information. The following packages have been upgraded to a later upstream version: samba (4.15.5). (BZ#2013596) Security Fix(es): * samba: Symlink race error can allow metadata read and modify outside of the exported share (CVE-2021-20316) * samba: Information leak via symlinks of existance of files or directories outside of the exported share (CVE-2021-44141) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Updated packages:
  • samba-winexe-4.15.5-5.el8.x86_64.rpm
  • samba-winbind-4.15.5-5.el8.x86_64.rpm
  • libsmbclient-4.15.5-5.el8.x86_64.rpm
  • libsmbclient-4.15.5-5.el8.x86_64.rpm
  • samba-common-libs-4.15.5-5.el8.x86_64.rpm
  • ctdb-4.15.5-5.el8.x86_64.rpm
  • samba-winbind-modules-4.15.5-5.el8.x86_64.rpm
  • samba-winbind-modules-4.15.5-5.el8.x86_64.rpm
  • python3-samba-test-4.15.5-5.el8.x86_64.rpm
  • samba-4.15.5-5.el8.x86_64.rpm
  • samba-test-4.15.5-5.el8.x86_64.rpm
  • samba-client-4.15.5-5.el8.x86_64.rpm
  • samba-winbind-clients-4.15.5-5.el8.x86_64.rpm
  • samba-krb5-printing-4.15.5-5.el8.x86_64.rpm
  • samba-common-4.15.5-5.el8.noarch.rpm
  • libwbclient-4.15.5-5.el8.x86_64.rpm
  • libwbclient-4.15.5-5.el8.x86_64.rpm
  • samba-pidl-4.15.5-5.el8.noarch.rpm
  • samba-test-libs-4.15.5-5.el8.x86_64.rpm
  • samba-common-tools-4.15.5-5.el8.x86_64.rpm
  • samba-winbind-krb5-locator-4.15.5-5.el8.x86_64.rpm
  • samba-libs-4.15.5-5.el8.x86_64.rpm
  • samba-libs-4.15.5-5.el8.x86_64.rpm
  • samba-client-libs-4.15.5-5.el8.x86_64.rpm
  • samba-client-libs-4.15.5-5.el8.x86_64.rpm
  • python3-samba-4.15.5-5.el8.x86_64.rpm
  • python3-samba-4.15.5-5.el8.x86_64.rpm
  • samba-vfs-iouring-4.15.5-5.el8.x86_64.rpm
  • libsmbclient-devel-4.15.5-5.el8.x86_64.rpm
  • libwbclient-devel-4.15.5-5.el8.x86_64.rpm
  • samba-devel-4.15.5-5.el8.x86_64.rpm
  • python3-samba-4.15.5-5.el8.aarch64.rpm
  • samba-test-libs-4.15.5-5.el8.aarch64.rpm
  • python3-samba-test-4.15.5-5.el8.aarch64.rpm
  • samba-test-4.15.5-5.el8.aarch64.rpm
  • samba-libs-4.15.5-5.el8.aarch64.rpm
  • samba-common-libs-4.15.5-5.el8.aarch64.rpm
  • samba-client-libs-4.15.5-5.el8.aarch64.rpm
  • samba-winbind-modules-4.15.5-5.el8.aarch64.rpm
  • ctdb-4.15.5-5.el8.aarch64.rpm
  • samba-client-4.15.5-5.el8.aarch64.rpm
  • samba-krb5-printing-4.15.5-5.el8.aarch64.rpm
  • samba-winbind-clients-4.15.5-5.el8.aarch64.rpm
  • samba-common-tools-4.15.5-5.el8.aarch64.rpm
  • samba-winbind-4.15.5-5.el8.aarch64.rpm
  • samba-4.15.5-5.el8.aarch64.rpm
  • samba-winbind-krb5-locator-4.15.5-5.el8.aarch64.rpm
  • libwbclient-4.15.5-5.el8.aarch64.rpm
  • libsmbclient-4.15.5-5.el8.aarch64.rpm
  • samba-vfs-iouring-4.15.5-5.el8.aarch64.rpm
  • samba-winbind-4.15.5-5.el8.ppc64le.rpm
  • libsmbclient-4.15.5-5.el8.ppc64le.rpm
  • samba-common-libs-4.15.5-5.el8.ppc64le.rpm
  • ctdb-4.15.5-5.el8.ppc64le.rpm
  • samba-winbind-modules-4.15.5-5.el8.ppc64le.rpm
  • python3-samba-test-4.15.5-5.el8.ppc64le.rpm
  • samba-4.15.5-5.el8.ppc64le.rpm
  • samba-test-4.15.5-5.el8.ppc64le.rpm
  • samba-client-4.15.5-5.el8.ppc64le.rpm
  • samba-winbind-clients-4.15.5-5.el8.ppc64le.rpm
  • samba-krb5-printing-4.15.5-5.el8.ppc64le.rpm
  • libwbclient-4.15.5-5.el8.ppc64le.rpm
  • samba-test-libs-4.15.5-5.el8.ppc64le.rpm
  • samba-common-tools-4.15.5-5.el8.ppc64le.rpm
  • samba-winbind-krb5-locator-4.15.5-5.el8.ppc64le.rpm
  • samba-libs-4.15.5-5.el8.ppc64le.rpm
  • samba-client-libs-4.15.5-5.el8.ppc64le.rpm
  • python3-samba-4.15.5-5.el8.ppc64le.rpm
  • samba-vfs-iouring-4.15.5-5.el8.ppc64le.rpm
  • libsmbclient-devel-4.15.5-5.el8.ppc64le.rpm
  • libwbclient-devel-4.15.5-5.el8.ppc64le.rpm
  • samba-devel-4.15.5-5.el8.ppc64le.rpm
Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.