[ALSA-2022:1796] Moderate: qt5-qtbase security update
Type:
security
Severity:
moderate
Release date:
2022-05-10
Description:
Qt is a software toolkit for developing applications. The qt5-base packages contain base tools for string, xml, and network handling in Qt. Security Fix(es): * qt: out-of-bounds write in QOutlineMapper::convertPath called from QRasterPaintEngine::fill and QPaintEngineEx::stroke (CVE-2021-38593) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Updated packages:
  • qt5-qtbase-common-5.15.2-4.el8.noarch.rpm
  • qt5-qtbase-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-private-devel-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-private-devel-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-mysql-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-mysql-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-examples-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-examples-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-odbc-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-odbc-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-postgresql-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-postgresql-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-gui-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-gui-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-devel-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-devel-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-static-5.15.2-4.el8.x86_64.rpm
  • qt5-qtbase-odbc-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-examples-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-devel-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-private-devel-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-mysql-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-postgresql-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-gui-5.15.2-4.el8.aarch64.rpm
  • qt5-qtbase-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-private-devel-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-mysql-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-examples-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-odbc-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-postgresql-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-gui-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-devel-5.15.2-4.el8.ppc64le.rpm
  • qt5-qtbase-static-5.15.2-4.el8.ppc64le.rpm
Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.