[ALSA-2022:0891] Moderate: httpd:2.4 security update
Type:
security
Severity:
moderate
Release date:
2022-03-15
Description:
The httpd packages provide the Apache HTTP Server, a powerful, efficient, and extensible web server. Security Fix(es): * httpd: NULL pointer dereference via malformed requests (CVE-2021-34798) * httpd: Out-of-bounds write in ap_escape_quotes() via malicious input (CVE-2021-39275) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Updated packages:
  • mod_md-2.0.8-8.module_el8.6.0+2872+fe0ff7aa.aarch64.rpm
  • httpd-manual-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.noarch.rpm
  • httpd-devel-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • mod_ldap-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • httpd-filesystem-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.noarch.rpm
  • mod_ssl-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • mod_session-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • httpd-tools-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • mod_proxy_html-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
  • httpd-2.4.37-43.module_el8.5.0+2630+51c6d843.2.alma.x86_64.rpm
Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.