[ALSA-2021:4231] Moderate: libwebp security update
Type:
security
Severity:
moderate
Release date:
2021-11-12
Description:
The libwebp packages provide a library and tools for the WebP graphics format. WebP is an image format with a lossy compression of digital photographic images. WebP consists of a codec based on the VP8 format, and a container based on the Resource Interchange File Format (RIFF). Webmasters, web developers and browser developers can use WebP to compress, archive, and distribute digital images more efficiently. Security Fix(es): * libwebp: out-of-bounds read in WebPMuxCreateInternal (CVE-2018-25009) * libwebp: out-of-bounds read in ApplyFilter() (CVE-2018-25010) * libwebp: out-of-bounds read in WebPMuxCreateInternal() (CVE-2018-25012) * libwebp: out-of-bounds read in ShiftBytes() (CVE-2018-25013) * libwebp: use of uninitialized value in ReadSymbol() (CVE-2018-25014) * libwebp: out-of-bounds read in ChunkVerifyAndAssign() in mux/muxread.c (CVE-2020-36330) * libwebp: out-of-bounds read in ChunkAssignData() in mux/muxinternal.c (CVE-2020-36331) * libwebp: excessive memory allocation when reading a file (CVE-2020-36332) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Updated packages:
  • libwebp-1.0.0-5.el8.i686.rpm
  • libwebp-devel-1.0.0-5.el8.i686.rpm
  • libwebp-devel-1.0.0-5.el8.x86_64.rpm
  • libwebp-1.0.0-5.el8.x86_64.rpm
  • libwebp-devel-1.0.0-5.el8.aarch64.rpm
  • libwebp-1.0.0-5.el8.aarch64.rpm
  • libwebp-1.0.0-5.el8.ppc64le.rpm
  • libwebp-devel-1.0.0-5.el8.ppc64le.rpm
Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.