[ALSA-2021:1796] Moderate: container-tools:rhel8 security, bug fix, and enhancement update
Type:
security
Severity:
moderate
Release date:
2021-05-18
Description:
The container-tools module contains tools for working with containers, notably podman, buildah, skopeo, and runc. Security Fix(es): * golang: crypto/ssh: crafted authentication request can lead to nil pointer dereference (CVE-2020-29652) * podman: Remote traffic to rootless containers is seen as orginating from localhost (CVE-2021-20199) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Updated packages:
  • buildah-1.19.7-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • buildah-tests-1.19.7-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • cockpit-podman-29-2.module_el8.4.0+2332+f4da7515.noarch.rpm
  • conmon-2.0.26-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • container-selinux-2.158.0-1.module_el8.4.0+2332+f4da7515.noarch.rpm
  • containernetworking-plugins-0.9.1-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • containers-common-1.2.2-8.module_el8.4.0+2332+f4da7515.alma.x86_64.rpm
  • crit-3.15-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • criu-3.15-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • crun-0.18-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • fuse-overlayfs-1.4.0-2.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • libslirp-4.3.1-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • libslirp-devel-4.3.1-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • oci-seccomp-bpf-hook-1.2.0-2.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • podman-3.0.1-6.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • podman-catatonit-3.0.1-6.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • podman-docker-3.0.1-6.module_el8.4.0+2332+f4da7515.noarch.rpm
  • podman-plugins-3.0.1-6.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • podman-remote-3.0.1-6.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • podman-tests-3.0.1-6.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • python3-criu-3.15-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • runc-1.0.0-70.rc92.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • skopeo-1.2.2-8.module_el8.4.0+2332+f4da7515.alma.x86_64.rpm
  • skopeo-tests-1.2.2-8.module_el8.4.0+2332+f4da7515.alma.x86_64.rpm
  • slirp4netns-1.1.8-1.module_el8.4.0+2332+f4da7515.x86_64.rpm
  • toolbox-0.0.8-1.module_el8.4.0+2332+f4da7515.noarch.rpm
  • udica-0.2.4-1.module_el8.4.0+2332+f4da7515.noarch.rpm
Notes:
This page is generated automatically and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.