[ALSA-2021:0734] Important: nodejs:12 security update
Type:
security
Severity:
important
Release date:
2021-03-04
Description:
Node.js is a software development platform for building fast and scalable network applications in the JavaScript programming language. The following packages have been upgraded to a later upstream version: nodejs (12.21.0). Security Fix(es): * nodejs: HTTP2 'unknownProtocol' cause DoS by resource exhaustion (CVE-2021-22883) * nodejs: DNS rebinding in --inspect (CVE-2021-22884) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
Updated packages:
  • nodejs-12.21.0-1.module_el8.3.0+2048+34fb5a07.x86_64.rpm
  • nodejs-devel-12.21.0-1.module_el8.3.0+2048+34fb5a07.x86_64.rpm
  • nodejs-docs-12.21.0-1.module_el8.3.0+2048+34fb5a07.noarch.rpm
  • nodejs-full-i18n-12.21.0-1.module_el8.3.0+2048+34fb5a07.x86_64.rpm
  • nodejs-nodemon-2.0.3-1.module_el8.3.0+2048+34fb5a07.noarch.rpm
  • nodejs-packaging-17-3.module_el8.3.0+2021+b7b41ca0.noarch.rpm
  • npm-6.14.11-1.12.21.0.1.module_el8.3.0+2048+34fb5a07.x86_64.rpm
Notes:
This page is generated automatically and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.