[ALSA-2021:2170] Important: glib2 security and bug fix update
Type:
security
Severity:
important
Release date:
2021-06-01
Description:
GLib provides the core application building blocks for libraries and applications written in C. It provides the core object system used in GNOME, the main loop implementation, and a large set of utility functions for strings and common data structures. Security Fix(es): * glib: integer overflow in g_bytes_new function on 64-bit platforms due to an implicit cast from 64 bits to 32 bits (CVE-2021-27219) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Bug Fix(es): * Refcounting issue causes crashes and slow workarounds (BZ#1953553)
References:
Updated packages:
  • glib2-2.56.4-10.el8_4.i686.rpm
  • glib2-2.56.4-10.el8_4.x86_64.rpm
  • glib2-devel-2.56.4-10.el8_4.i686.rpm
  • glib2-devel-2.56.4-10.el8_4.x86_64.rpm
  • glib2-doc-2.56.4-10.el8_4.noarch.rpm
  • glib2-fam-2.56.4-10.el8_4.x86_64.rpm
  • glib2-static-2.56.4-10.el8_4.i686.rpm
  • glib2-static-2.56.4-10.el8_4.x86_64.rpm
  • glib2-tests-2.56.4-10.el8_4.x86_64.rpm
Notes:
This page is generated automatically and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.