[ALSA-2021:1935] Low: rust-toolset:rhel8 security, bug fix, and enhancement update
Type:
security
Severity:
low
Release date:
2021-05-18
Description:
Rust is a systems programming language that runs blazingly fast, prevents segfaults, and guarantees thread safety. The following packages have been upgraded to a later upstream version: rust (1.49.0). (BZ#1896712) Security Fix(es): * rust: use-after-free or double free in VecDeque::make_contiguous (CVE-2020-36318) * rust: memory safety violation in String::retain() (CVE-2020-36317) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Additional Changes: For detailed information on changes in this release, see the AlmaLinux Release Notes linked from the References section.
Updated packages:
  • cargo-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • cargo-doc-1.49.0-1.module_el8.4.0+2145+1a463e08.noarch.rpm
  • clippy-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rls-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rust-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rust-analysis-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rust-debugger-common-1.49.0-1.module_el8.4.0+2145+1a463e08.noarch.rpm
  • rust-doc-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rust-gdb-1.49.0-1.module_el8.4.0+2145+1a463e08.noarch.rpm
  • rust-lldb-1.49.0-1.module_el8.4.0+2145+1a463e08.noarch.rpm
  • rust-src-1.49.0-1.module_el8.4.0+2145+1a463e08.noarch.rpm
  • rust-std-static-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rust-toolset-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
  • rustfmt-1.49.0-1.module_el8.4.0+2145+1a463e08.x86_64.rpm
Notes:
This page is generated automatically and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.